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MICROSOFT ACCESS 2007 – BOOK 2 
4.1 INTRODUCTION TO ACCESS 

FIRST ENCOUNTER WITH ACCESS 2007  

P 205 

Access is activated by means of Start, Programs, Microsoft Access or clicking on the icon. 

The window opened by this process looks different from the previous versions: 

It offers online templates, but the basics are still there: New Blank Database and Open Recent Database.

 

• Load Access 2007. 

Activity 1 P 205: 

• Open the existing database file CD_database. 

You will see that a database can contain different components: 
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On the left task pane, a drop down menu displays the various components of a database: 

 

 

 

 

 

 

 

 

TABLES 

The default component is tables and the first table will be 
displayed. 

Close the table by clicking on the Office 2007 button and selecting 
Close Database.  

The methods to move within the table are still the same as the 
previous version. 

Tables 
Queries 
Forms 
Reports 
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QUERIES 

• Select Queries from the drop-down menu and open the Query ‘Owners, Eminem CDs’. 

Note that this query only contains the titles, owners and contact details of all CDs by 
Eminem. 

 

 

FORMS 

• Click on Forms, select Input form. 

• Display different records by using navigation bar. 

• Close the form. 

 

 

 

 

REPORTS 

• Select Reports from drop-down menu. 

• Open CDs grouped by genre, then artist. 

• Close the report. 
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MORE ABOUT TABLES 

CHANGING THE APPEARANCE OF A TABLE 

Change the colour of the text, lines and background. 

Activity 3 P 209 

Change the font type and size. 
Display some of the gridlines. 

The Home tab, Font group is where all this can be 
changed: 
 
 
 
 
 

Activity 4 P 210 

CHANGE THE CONTENTS OF A TABLE 

Activity 5 P 211 

Same as previous. 

PRINTING OF A TABLE 

The print option is selected from the Office button. 

 

 

 

 

 

 

 

 

 

Activity 6 P 212 
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CREATING A TABLE 

TYPES OF DATA THAT CAN BE STORED 

The same as previous versions (see Data Type & formatting group on the Datasheet 
tab). It also makes provision for attachments and the Lookup feature is found with the 
Fields & Columns group on the Datasheet tab in the Datasheet view.  

 

 

 

In the Design view, the Lookup Wizard still appears in the dropdown list:  

 

 

The icon for the primary key in Access 2007 can be found under the Design tab in the Tools group and can be 
clicked to designate the selected field as the primary key. 

 

Note that the Lookup Wizard can also be accessed by clicking Lookup Column in the Tools group. 
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DIFFERENT VIEWS OF A TABLE 

A table can be displayed in Design View by clicking on the View icon on the Design tab.  

 

The Design View of the CD_table from the database CD_database looks as follows: 

 

 

Activity 7 P 214 

  

Activity 8 P 215 

Click on a field in the top 
part to view the properties in 
the lower part 

Field Properties 

An explanation of each 
property is displayed here 
when you click on the 
property 
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CREATE A TABLE 

• Create a new database. 

Activity 9 P 215 

o Open Access. 

o Click  
or 

o Click on Office button, New. 
o Choose Blank Database. 
o Specify the applicable disk drive and type Sport in the File name box. 
o Click on Create. 
o A database window for a new database will appear. 

 

• Start creating a new table. 
o A new table is displayed in the Datasheet view. 
o Choose Design View. 
o Save table as Students. 

 

The rest remains the same as before. 

 

Activity 10 P 217 

Activity 11 P 218 

Activity 12 P 219 

 

Activity 13 P 220 
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4.2 QUERIES AND REPORTS 

FORMULATION OF SIMPLE CRITERIA 

Same as previous version . 

 

ENQUIRIES WITH A FILTER 

To do this, complete the following instructions in the table in Datasheet View: 

 

• Right-click in the field to which the criteria must be applied. 

• Select the option you want to filter for from Text Filters. 

• Some preset options can be selected from the bottom of the 
list. 

 

 

The records found as a result of the filter are shown. The total 
number of records in the table will be displayed when the filter is removed. 

Remove the filter as follows: 

• Right-click again in the field where the filter must be removed and choose Clear Filter from Genre. 

Activity 1 P 226 

Activity 2 P 227 

 

Activity 3 P 227 
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ENQUIRIES USING ACCESS QUERIES 

HOW DOES A QUERY WORK? 

 

 

 

 

 

The names of different queries that have already been created 
and are saved as part of the database. 

 

Activity 4 P 229 

 

Activity 5 P 230 

CREATING A QUERY 

You must still work with CD_database. 

Activity 6 P 230 

• From the Design view, select the Create tab and select Query Design from the Other group. 

 

The rest remains the same as previous, except that to display the results of the query, click the Run icon in the 
Results group on the Design tab or choose the Datasheet view.  

Activity 7 P 232 

Activity 8 P 234 

 

Activity 9 P 235 
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REPORTS 

DIFFERENT SECTIONS IN A REPORT 

Same as previous. 

CREATING A BASIC REPORT 

Activity 11 P 237 

• Click the Create tab. 

Activity 12 P 237 

• Use the Report wizard in the 
Reports group to create the 
report. 

 

The rest remains the same as previous, except that the Styles differ – select the Access 2007 style instead. 

Activity 13 P 240 

 

Activity 14 P 240 

CHANGING THE APPEARANCE OF THE REPORT 

Summary of the basic changes that can be made to the appearance of a report that have changed in Office 2007: 

Changes that can be made Steps that must be followed 
Moving the controls to 
another position 

 Click on the border of the control. 
 After the pointer changes to a cursor with 4 arrows, you can drag the 

control to a new position. (Not the open hand as in previous versions.) 
Add a label or text box  Go to the Design tab and select an icon from the Controls group. 

 
 Click on the icon for the control you want to add (Aa for label and ab for a 

Text box.) 
 Click on the place in the report where you want to add the control. 

 

Activity 15 P 242 

  

Activity 16 P 242 
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CREATING REPORT WITH GROUPINGS 

This works the same as in previous versions. 

Activity 17 P 244 

Activity 18 P 244 

 

Activity 19 P 245 

CALCULATIONS IN A REPORT 

Functions are the same as in previous versions. 

Activity 20 P 246 

Activity 21 P 247 

Activity 22 P 248 

Activity 23 P 248 

 

Activity 24 P 250 
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4.3 FORMS 

VIEWING AND USE OF AN EXISTING FORM 

 

After a form has been opened, you can click on any button to view a form in Form View, Design 
View and Datasheet view. 

 

 

 

CREATING A FORM USING A WIZARD 

Activity 1 P 254 

• Open the database AnimalHospital. 

Activity 2 P 255 

• Select Forms from the dropdown list in the left task pane. You 
will see that there are currently no forms. 

• Select the Create tab and click on More Forms in the Forms 
group to select Form Wizard from the dropdown list. 

The rest remains the same as previous, except that there is no 
Normal style. Select the Access 2007 style instead. 

 

 

Activity 3 P 256 

IMPROVING AN EXISTING FORM 

BASIC ASPECTS THAT WILL IMPROVE A FORM’S LAYOUT 

Basic aspects stay the same in Office 2007. 
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TIPS FOR WORKING IN DESIGN VIEW 

 

Aligning controls 
Align controls with 
one another 

Select the controls, choose the Arrange tab 
and select the desired layout from the 
Control Layout group. 
The Arrange tab is available in the Layout 
view and in the Design view. 

To change the 
spacing between the 
controls and the 
margins in the 
controls 

Select the controls, choose the Arrange tab and select the desired layout from the Control 
Layout group 
or Control Margins. 
 
 
 
 

To change the size 
and position of the 
controls 

Select the controls, choose Arrange tab and select the desired layout from the Size group 
and Position group. 
 
 
 
 
 

To change the 
alignment of the 
controls 

Select the controls, choose Arrange tab and select the desired layout from the Control 
Alignment group. 
 
 
 
 
 
Drawing Tools: These are all available options on the Design tab 

Images Click on the Logo button. You will be presented with an Insert Picture dialog box where 
you can simply choose your picture and then click OK. You can set the size and position of 
the image with the mouse.  

Formatting: These are all available options on the Format tab 
Formatting options From the Layout view, click on the Format tab. 

 

Activity 4 P 257 

 

Activity 5 P 258 
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THE USE OF COMBO BOXES IN A FORM 

• The Control Wizards button can be found on the Design tab in the Controls group. (The button must be 

Activity 6 P 259 

highlighted to show that it is “on”.)  

The rest is same as previous. 

 

Activity 7 P 259 

PHOTOGRAPHS AS FIELDS IN A DATABASE 

Same as before. 

Activity 8 P 260 

Activity 9 P 261 

 

Activity 10 P 262 
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6.2 COLLABORATION AND INTEGRATION 

CONVERTING BETWEEN FILE FORMATS – ACCESS (P 337) 

EXPORTING DATA FROM AN ACCESS TABLE/QUERY 

Exporting to Excel  

Click the External Data tab and click Excel in the Export group. 

 

The following appears: 

• Make sure that the correct drive, folder and file 
name appear. 

• Select the correct file format. 

• Select the desired options. 

• Click OK. 

 

 

 

Exporting to text format with a separator character 

Click the External Data tab and click on Text File in the Export group. 

The following appears: 

• Make sure that the correct drive, folder and file 
name appear. 

• Select the correct file format. 

• Select the desired options. 

• Click OK. 

 

 

 

• Follow the Export Wizard as before. 
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Exporting to Rich Text format 

Click the External Data tab and click on Word in the Export group. 

The following appears: 

• Make sure that the correct drive, folder and file 
name appear. 

• Select the correct file format. 

• Select the desired options. 

• Click OK. 

 

 

 

The table/report/query is now in .rtf format. 

CONVERTING TO PDF FORMAT (FOUND WITH VISTA OPERATING SYSTEM)  (NEW) 

Click the External Data tab and click on Text File in the Export group. 

The following appears: 

• Make sure that the correct drive, folder 
and file name appear. 

• Click Publish. 

 

CONVERTING TO A DATABASE IN A LOWER VERSION 

Activity 10 P 337 

Click on the Office Button. 

Select the version to which you want the database to be converted. 
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IMPORTING DATA FROM A SPREADSHEET TO A TABLE IN ACCESS 

Click the External Data tab and click on Excel in the Import group. 

 

The following appears: 

• Click on Browse… 

• Make sure that the correct drive, folder and 
file name appear. 

• Click Open. 

• Select the desired options. 

• Click OK. 

Follow the Import Spreadsheet Wizard as before. 

Activity 11 P 339 

IMPORTING DATA FROM A TEXT FILE TO A TABLE IN ACCESS 

Activity 12 P 342 

Click the External Data tab and click on Text File in the Import group. 

The following appears: 

• Click on Browse… 

• Select the correct drive, folder and file name 
of the file you want to import. 

• Click Open. 

• Select the desired options. 

• Click OK. 

Follow the Import Spreadsheet Wizard as before. 

 

Activity 13 P 342 
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MICROSOFT ACCESS 2007 – BOOK 3 
5.1 DESIGN A SIMPLE DATABASE 

DECIDE WHAT DATA SHOULD BE STORED 

As before. 

Activity 1 P 164 

DESIGN WITH A FOCUS ON IMPROVING DATA CAPTURE 

Activity 2 P 165 

As before. 

Activity 3 P 169 

Activity 4 P 170 

Activity 5 P 171 

 

Activity 6 P 171 

5.2 CALCULATIONS IN QUERIES AND REPORTS 

CALCULATED FILEDS IN QUERIES 

As before. 

Activity 1 P 173 

Activity 2 P 173 

CALCULATED FIELDS IN REPORTS 

Activity 3 P 174 

CALCULATIONS ON FIELDS WITHOUT GROUPING 

Activity 4 P 175 

As before. 

Activity 5 P 177 
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THE USE OF FUNCTIONS IN GROUPING 

 

 

As before, except to create a footer for the field Shopping Centre, do the following: 

• Click Group & Sort in the Grouping & Totals group. 

The following will be displayed: 

 

 

 

• Click on More. 

The following will be displayed: 

 

Click on the arrow without footer secton and select with a footer section. 

The Shopping Centre footer will now be displayed. 

The rest as in previous versions. 

Look at the other options at Group, Sort and Total. 

 

Activity 6 P 180 

Activity 7 P 180 

Activity 8 P 181 

 

Activity 9 P 181 
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